Results 1 to 8 of 8

Thread: AFS4500sEE Problems

  1. #1

    AFS4500sEE Problems

    I have a NOS AFS4500 that I purchased and am having problems with getting certain engine instruments to function.
    I had a Dynon FD180 and D10A in my aircraft so the pinouts were very similar on the exchange. All engine instruments were functioning normal.
    My issues are the following:

    The gages are displayed and configured just not getting any info.
    I get No F/F reading using my original Flowscan or a new FT60 Red Cube.
    No RPM reading off Pmags using either R or L input with or without 5v zener diode. A T30 tach works fine so it's not my Pmag signal
    No CHT/EGT which was a direct cable swap with Dynon

    The other engine instruments are working.

    I'm currently swapping back to my Dynon FD180 in the interim.

    Is there something I'm missing or does my 4500 need servicing


  2. #2
    Fuel flow, do you see any counts in the CHECK --> MAINT --> ADMIN --> CALIBRATION --> Fuel Flow menu?
    Try relocating the fuel flow power wire from pin 15 to pin 29. The 5V on pin 15 is technically undervolting the sensor, it usually works but when it doesn't we have had success with having customers relocate to 8V power available on pin 29.

    RPM try with the emag in 12V mode (no diode) but wire to our EMS connector pin 33 instead of the default pin 32.

    Dynon EGT/CHT probes will not work with an AF-4500. The AFS internal EMS only works with ungrounded Type J and K thermocouples.

  3. #3
    Thanks for responding Jonathon
    I originally tried the 12v mode on the each pmag using pin 33 the result was no rpm. I added diodes to each with the same result.

    Fuel Flow: I initially used my origingal FloScan on 12v without any fuel flow. Next I installed a new FT60 on 12 volts without success I will look to see if there are any counts but for now In the interim, I've re-pinned to my Dynon 180. The Dynon indicated a fuel flow so the FT60 is good.

    Tomorrow I'll check on the Tach when our weather improves.

    I'll look into a new set of probes

  4. #4
    I'm still not getting RPM while my FD180 works on either Pmag and a T-30 tach functions correctly.
    I'm curious about the RPM Ground that I assume is used with a mag sensor install only.
    Is that correct?
    Do you still service these units? If so, what needs to be done from my end?


  5. #5
    Yes the RPM ground and power are only for the sensor that we make to install in a magneto. Is there a resistor in series with the wire from the emag? If there is, take it out and wire direct to the 4500. You can monitor the total number of pulses aka counts the EFIS has received on the CHECK --> MAINT --> ADMIN --> CALIBRATION --> RPM screen. Do you see any counts when wired to an emag?

    Unhook the engine sensor connector, put a test wire into pin 32, tap the other end to ground. Do you see RPM counts increase? Move the test wire over to pin 33, tap the free end to 12V, do you see RPM counts increase?

  6. #6
    Here are the results of the test. There is no resistor in series with the wire from the pmag.
    I started up and didn't have RPM. I do seeing counts with that and they run up to 1000 and go back to 0 to 1000 and repeat.
    I also did the pin 32 to ground which I saw a more stabilized counts but with a much slower increase.
    Pin 33 to +12v yielded approximately the same results as the pin 32 test to ground.
    The Dynon worked fine on either pmag lead displaying correct RPM.

  7. #7
    I guess you could try the 12V default emag signal in the 5V pin 32 RPM input, but spoiler alert, if your EFIS has anything but the newest hardware revision of the engine board, this will cook the op-amp.

    Only other thing to recommend is send the EFIS in and we can take a look at it.

  8. #8
    Thanks Jonathan.
    I'll send it in.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts