Results 1 to 3 of 3

Thread: Screen not working

  1. #1

    Screen not working

    After normal startup of my RV8 the screen of my AF-3400 EFIS suddenly became unreadable? Tried multiple restart of the unit but still the same screen.

    Name:  IMG_1526.jpg
Views: 39
Size:  65.1 KB

    /Christian

  2. #2
    Most likely the LCD cable has some corrosion on the cable contacts. Email support to get the document on how to fix it.
    Rob Hickman
    Advanced Flight Systems Inc.

  3. #3
    Hello Christian,
    The ribbon cable that connects your LCD to the EFIS motherboard has worked loose and/or is lightly corroded.

    If you are comfortable working on electronics, private message me your email, and I will send you a document that will show how you may disassemble your EFIS and reseat the ribbon cable. Before reconnecting the ribbon, You will also want to clean the connectors with a little dab of electrical contact cleaner (Deoxit or CRC are good choices). After reconnecting the ribbon, you will want to build a bridge of hot glue over the connectors, to prevent this from happening again.

    If you are inexperienced with working on electronics or are uncomfortable with any part of this process, seek professional assistance, or consider sending us the EFIS to effect the repair. It is not a terribly difficult job, but it is possible to damage the EFIS further if you are not careful and attentive while disassembling and reassembling. We did just recently have to repair an AF-3400 that was further damaged in a customer repair. The customer fixed the LCD ribbon cable without issue, but ended up breaking the connector between the engine monitor and the motherboard.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •