Results 1 to 3 of 3

Thread: RPM with E-Mags

  1. #1

    RPM with E-Mags

    Hi, Im not sure how to start a new thread here but this is along the lines of my question. I'm helping a friend Rich Adams with his AFS-5600 in a Sportsman. We just finished the SV 261 upgrade. He now seems to have a 2nd rpm sensor failure in about 30 hrs with Slick mags. Looking at the install manual for the EFIS it clearly shows no mag sensor but ignition switch connections to pin 32 and 33 for L & R mags with a 30K resistor inline of each shielded input wire. Is this the proper way to eliminate the mag sensor issue? This is how my electronic tach is wired in my airplane and Shawn M stated that this would be an alternative to the mag sensor tach method.

    Thanks for any help on this. Cordially

    Kurt Malerich

  2. #2
    Advanced Flight Systems, Inc. Shawn McGinnis's Avatar
    Join Date
    Sep 2012
    Location
    Canby, OR
    Posts
    537
    Pins 32 and 33 for L & R mags would be on an SV-EMS-220/221 not an internal Advanced Deck EE or EM EFIS. If this type of connection is needed we have an 71,420 external adapter board that would connect to an Advanced Deck EE or EM EFIS.
    Shawn McGinnis

    Advanced Flight Systems, Inc.
    support@advanced-flight-systems.com

  3. #3
    Shawn...Thanks for the reply. We talked to you on the phone and got your answer. The new mag sensor has cured the problem. We shielded the sensor wire but not the 5v and ground from the mag to the firewall just to make sure it was isolated. This is the 3rd sensor in 180 hours since new.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •