Results 1 to 2 of 2

Thread: EGT and CHT Reading Errors

  1. #1

    EGT and CHT Reading Errors

    I just fired up the new 5800 system with Engine Board. All of my sensors have been calibrated and are functioning, except EGT and CHT.

    The EGT and CHT readings are jumping around between 200 to 250, with the engine cold, not running at 80* ambient temp. The probes are wired to the connector with the appropriate wire.

    Sensors are new, full Dynon EMSKIT-L6F package.

    How can I calibrate these?

    Thanks
    Frank
    Last edited by Frank D; 07-02-2015 at 07:28 AM.

  2. #2
    Advanced Flight Systems Shawn McGinnis's Avatar
    Join Date
    Sep 2012
    Location
    Canby, OR
    Posts
    715
    Dynon probes are most likely grounded probes which won't work with the AFS Engine Board.

    http://wiki.dynonavionics.com/Common...ounded_type.3F
    Shawn McGinnis

    Advanced Flight Systems
    support@advanced-flight-systems.com

Similar Threads

  1. Erratic RPM reading
    By darnold in forum AF-3400s, AF-3500s, AF-4500s ... General Discussion
    Replies: 2
    Last Post: 08-09-2014, 11:30 AM
  2. FP reading
    By dougweil in forum Engine Sensor Installation Questions
    Replies: 6
    Last Post: 01-27-2014, 11:27 AM
  3. Max g reading after aerobatics
    By RKURRLE in forum AF-3400s, AF-3500s, AF-4500s ... General Discussion
    Replies: 1
    Last Post: 06-10-2012, 09:13 PM
  4. Magnetic Heading Errors
    By Rob Hickman in forum Technical Support Documents
    Replies: 2
    Last Post: 01-08-2012, 12:27 PM
  5. Amp reading
    By dougweil in forum Engine Sensor Installation Questions
    Replies: 1
    Last Post: 09-19-2011, 01:29 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •